Microsoft Certified Identity And Access Administrator Associate · Free Practice Question Medium
Question 7
Your organization has recently installed Azure AD Connect to synchronize all users and groups from the on-premises Active Directory to the Azure Active Directory. However, during the synchronization process, you encountered an error message stating, "UPN Suffix is not verified with Azure AD Tenant." What could be a possible reason for this error?
-
A
A user identity does not have the location attribute and cannot sync properly.
-
B
The organization did not verify their company domain with their registrar.
-
C
The organization did not configure a connected organization with Entitlement Management.
-
D
Azure AD is running under the free subscription and needs to be upgraded to Azure AD
Premium P1.
Reveal correct answer
Correct answer: B
Explanation
Answer A is incorrect. A user identity without a supplied location attribute would not be the cause of this error message.
Answer B is correct. To avoid this error, an organization must supply and verify its domain name through the custom domain section of Azure Active Directory. After providing the necessary information, the proper TXT/MX records must be supplied to the domain name registrar to verify ownership. Incomplete steps in this process would result in an error message.
Answer C is incorrect. A connected organization with Entitlement Management would not lead to the error message. It is not a possible cause of this error.
Answer D is incorrect. AD Connect will work using the Free tier of Azure Active Directory. A Premium Pl subscription is not required.
If you want to learn more, go to:
Microsoft Entra Connect: Troubleshoot object synchronization - Microsoft Entra ID | Microsoft Learn
Discussion
Think the marked answer is wrong, or have a better explanation? Share it below — comments appear after review.
