AWS Certified Sysops Administrator Associate · Free Practice Question Medium
Question 54
A company launched a static website using Amazon S3 which is being used by thousands of users from around the world. Soon after launch the website users started reporting 503 service unavailable errors.
What is the most likely cause of these errors?
-
A
There is an issue with the S3 Transfer Acceleration service.
-
B
The users do not have the correct permissions to access the website.
-
C
The request rate to Amazon S3 is too high.
-
D
The pre-signed URL has expired and no longer exists.
Reveal correct answer
Correct answer: C
Explanation
A 503 service unavailable error is most likely caused by too many requests coming in within a very short period of time. This can be an issue with Amazon S3 for extremely high request rates.
CORRECT: "The request rate to Amazon S3 is too high" is the correct answer.
INCORRECT: "There is an issue with the S3 Transfer Acceleration service" is incorrect. Transfer acceleration is used for uploading data to S3 so it is not related to static websites.
INCORRECT: "The pre-signed URL has expired and no longer exists" is incorrect. This would not give a 503 service unavailable error as the page would not exist.
INCORRECT: "The users do not have the correct permissions to access the website" is incorrect. A permissions error would not be a 503 service unavailable, you would get an access denied error instead.
References:
https://aws.amazon.com/premiumsupport/knowledge-center/http-5xx-errors-s3/
Save time with our AWS cheat sheets:
Discussion
Think the marked answer is wrong, or have a better explanation? Share it below — comments appear after review.
