AWS Certified Sysops Administrator Associate · Free Practice Question Medium
Question 20
A user is attempting to connect to an Amazon Linux instance using SSH and is experiencing errors. A SysOps Administrator has checked the configuration including key pairs, security groups, and network ACLs and confirmed that the user can connect to other instances in the same subnet. What can the Administrator do to further troubleshoot the issue?
-
A
Run the AWSSupport-TroubleshootSSH automation.
-
B
Check that there is an internet gateway attached to the VPC.
-
C
Attach an Elastic IP address to the instance.
-
D
Use Trusted Advisor to check the SSH configuration.
Reveal correct answer
Correct answer: A
Explanation
AWSSupport-TroubleshootSSH installs the Amazon EC2Rescue tool and then checks for and corrects some issues that cause remote connection errors when connecting to a Linux machine through SSH. Run the AWSSupport-TroubleshootSSH automation to automatically repair issues by subnet, S3 buckets, or IAM role.
CORRECT: "Run the AWSSupport-TroubleshootSSH automation" is the correct answer.
INCORRECT: "Check that there is an internet gateway attached to the VPC" is incorrect. The user would be unable to connect to other instances in the same subnet if an internet gateway was not attached.
INCORRECT: "Use Trusted Advisor to check the SSH configuration" is incorrect. Trusted Advisor will not advise on SSH configuration issues.
INCORRECT: "Attach an Elastic IP address to the instance" is incorrect. The instance does not necessarily need an Elastic IP address. A public IP address will do, and other instances are contactable so the subnet must be configured to automatically assign public IP addresses.
References:
https://aws.amazon.com/premiumsupport/knowledge-center/ec2-ssh-errors-automation-workflow/
Save time with our AWS cheat sheets:
Discussion
Think the marked answer is wrong, or have a better explanation? Share it below — comments appear after review.
