AWS Certified Developer Associate · Free Practice Question Medium

Question 18

An application is running on a cluster of Amazon EC2 instances. The application has received an error when trying to read objects stored within an Amazon S3 bucket. The bucket is encrypted with server-side encryption and AWS KMS managed keys (SSE-KMS). The error is as follows:

Service: AWSKMS; Status Code: 400, Error Code: ThrottlingException

Which combination of steps should be taken to prevent this failure? (Select TWO.)

  • A

    Use more than once customer master key (CMK) to encrypt S3 data

  • B

    Contact AWS support to request an S3 rate limit increase

  • C

    Perform error retries with exponential backoff in the application code

  • D

    Import a customer master key (CMK) with a larger key size

  • E

    Contact AWS support to request an AWS KMS rate limit increase

Reveal correct answers

Correct answers: C, E

Explanation

AWS KMS establishes quotas for the number of API operations requested in each second. When you exceed an API request quota, AWS KMS throttles the request, that is, it rejects an otherwise valid request and returns a ThrottlingException error like the following one.

As the error indicates, one of the recommendations is to reduce the frequency of calls which can be implemented by using exponential backoff logic in the application code. It is also possible to contact AWS and request an increase in the quota.

CORRECT: "Contact AWS support to request an AWS KMS rate limit increase" is a correct answer.

CORRECT: "Perform error retries with exponential backoff in the application code" is a correct answer.

INCORRECT: "Contact AWS support to request an S3 rate limit increase" is incorrect as the error indicates throttling in AWS KMS.

INCORRECT: "Import a customer master key (CMK) with a larger key size" is incorrect as the key size does not affect the quota for requests to AWS KMS.

INCORRECT: "Use more than once customer master key (CMK) to encrypt S3 data" is incorrect as the issue is not the CMK it is the request quota on AWS KMS.

References:

https://docs.aws.amazon.com/kms/latest/developerguide/requests-per-second.html

Save time with our AWS cheat sheets:

https://digitalcloud.training/aws-kms/

Discussion

Think the marked answer is wrong, or have a better explanation? Share it below — comments appear after review.

You must be logged in to post a comment.

Preparing For

Your Certification?

255+ certifications
Detailed explanations
Free PDF samples

Has All The Questions You Need