AWS Certified Sysops Administrator Associate · Free Practice Question Easy
Question 57
A SysOps Administrator created an AWS CloudFormation template and attempted to use it for the first time to create a new stack. The stack creation failed with a status of ROLLBACK_COMPLETE. The issues in the template have been resolved and the administrator wishes to continue with the stack deployment.
How can the administrator continue?
-
A
Run a validate-template command.
-
B
Relaunch the template to create a new stack.
-
C
Perform an update-stack action on the failed stack.
-
D
Run the execute-change-set command.
Reveal correct answer
Correct answer: B
Explanation
The ROLLBACK_COMPLETE status indicates the successful removal of one or more stacks after a failed stack creation or after an explicitly canceled stack creation. Any resources that were created during the create stack action are deleted.
This status exists only after a failed stack creation. It signifies that all operations from the partially created stack have been appropriately cleaned up. When in this state, only a delete operation can be performed.
CORRECT: "Relaunch the template to create a new stack" is the correct answer.
INCORRECT: "Run the execute-change-set command" is incorrect. You cannot create a change set for a stack in the ROLLBACK_COMPLETE state.
INCORRECT: "Perform an update-stack action on the failed stack" is incorrect. You cannot update a stack in the ROLLBACK_COMPLETE state.
INCORRECT: "Run a validate-template command" is incorrect. This will only validate the JSON or YAML code in the template file is correct.
References:
https://docs.aws.amazon.com/AWSCloudFormation/latest/UserGuide/using-cfn-describing-stacks.html
Save time with our AWS cheat sheets:
Discussion
Think the marked answer is wrong, or have a better explanation? Share it below — comments appear after review.
