AWS Certified Sysops Administrator Associate · Free Practice Question Medium
Question 56
A network administrator made a change to the networking configuration of an Amazon VPC. After the change, an application server running on Amazon EC2 is unable to connect to an Amazon RDS MySQL database. A SysOps Administrator must identify the root cause.
What should the SysOps Administrator analyze?
-
A
Amazon RDS MySQL error logs.
-
B
Amazon Auto Scaling logs.
-
C
VPC Flow Logs.
-
D
Amazon Elastic Load Balancing logs.
Reveal correct answer
Correct answer: C
Explanation
A change was made to the network and this is the most likely cause of the issue. Therefore, the investigation should focus on the checking the network layer.
VPC Flow Logs is a feature that enables you to capture information about the IP traffic going to and from network interfaces in your VPC. Flow logs can help you with a number of tasks, such as:
• Diagnosing overly restrictive security group rules.
• Monitoring the traffic that is reaching your instances.
• Determining the direction of the traffic to and from the network interfaces.
CORRECT: "VPC Flow Logs" is the correct answer.
INCORRECT: "Amazon Elastic Load Balancing logs" is incorrect as an ELB is not placed between an application server and an RDS database.
INCORRECT: "Amazon Auto Scaling logs" is incorrect. Auto Scaling is unlikely to be the root cause of this issue, the network layer should be investigated.
INCORRECT: "Amazon RDS MySQL error logs" is incorrect. It is unlikely that there will be anything particularly useful in the RDS MySQL error logs to diagnose the issue if it has been caused by a network change.
References:
https://docs.aws.amazon.com/vpc/latest/userguide/flow-logs.html
Save time with our AWS cheat sheets:
Discussion
Think the marked answer is wrong, or have a better explanation? Share it below — comments appear after review.
